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1. Introduction

The evaluation kit is designed for low cost WIFI IoT camera based on ArduCAM-Mini-2MP and
ArduCAM-ESP8266-Nano-V2 modules. Users can implement a 2MP WIFI camera using HTTP or
Websocket protocol on ESP8266, and the camera can act as an AP and mobile phone/PC can be
connected to the camera directly or act as a Station which connected to the home router. The kit
can take 2MP full resolution JPEG still image, but streaming low resolution low frame rate video due
to the limitation of ESP8266. The kit can be USB powered or battery powered with build in charging
circuits. The kit can also be used separately, it is identical to an ArduCAM-Mini-2MP camera and a
ESP8266 Nano V2 module. The highlight of Version2 is that the ESP8266 can be put into deep sleep
mode in order to be used in battery powered applications.
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2. Kit Contents

»  ArduCAM-Mini-2MP x1

» ArduCAM-ESP8266-Nano-V2 x1

» Battery power cable x1

Note: No battery is included, need to buy from local.

. Features

3
» 2MP image sensor OV2640, support JPEG

» M12 mount or CS mount lens holder with changeable lens options
» 12C interface for the sensor configuration

» SPlinterface for camera commands and data stream

» Build in Lithium battery recharging 3.7V/500mA max
> Build in SD/TF card socket
» Build in micro USB-Serial (CH340g) convertor
» Compatible with Arduino IDE
» Deep sleep mode
» Small form of factor
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4. Wiring Diagram
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5. Getting Started ESP8266 with Arduino IDE

5.1 Installing with Boards Manager
Install Arduino 1.6.8 from the Arduino website. Starting Arduino and open Preferences

window and entering the following link into Additional Board Manager URLs field. You can add
multiple URLs, separating them with commas:

http://www.arducam.com/downloads/ESP8266 UNO/package ArduCAM index.json

Preferences X
Settings Network

Sketchbook location:

C:\Users\zk109\Documents\Arduino Browse

Editor language: English (English) v (requires restart of Arduino)

Editor font size: 12

Interface scale: [ sutomatic (100 2 & (requires restart of Arduino)

Show verbose output during: [ ] compilation [ Jupload

Compiler warnings: None v

[Opisplay line numbers

[ Enable Code Folding

M verify code after upload

[JUse external editor

[ Check for updates on startup

[ Update sketch files to nex extension on save (.pde —=> .ino)

[ Save when verifying or uploading

Additional Boards Manager URLs: lhttp://sww. arducam. com/downloads/ESP8266 UNO/packaze ArduCAM index json i
More preferences can be edited directlv in t‘n-- file
IC.\Users\ 109\AppData\Local \Arduinol5\preferences. txt I

edi +h Arduino is not running)

(s
0K Cancel

Note that the installed package source file is located in the C:\Users\Your computer
name\AppData\Local\Arduino15\ folder.

Open Boards Manager from Tools ->Board menu and install ArduCAM_ESP8266_UNO add-on


http://www.arducam.com/downloads/ESP8266_UNO/package_ArduCAM_index.json
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package.

!file Edit Sketc @ elp

i @ sketch jun03a | Arduino 1.8.2 - O

sketch_jun03a
Boards Manager X
Type nl ~ | |[Filter your search

EMORO 2560 by Inovatic-ICT )

Boards included in this package:
EMoRo 2560. Board based on ATmega 2560 MCU.

Online hel
More info

AMEL-Tech Boards by replaced by Arrow Boards
Boards included in this package:
SmartEverything Fox.

Online help

More info

ArduCAM_ESP8266_UNO by ArduCAM
Boards included in this package:
ArduCAM ESP8266 UNO.

Online help
More info

Arduino Yin on COM1

Note if you download failed, you need to delete the C:\Users\Your computer name\AppData\
Local\Arduino15\ folder, and then restart the Arduino IDE, repeat the above operation.

i v|o| | s=ad. £
e packages 2017-06-03 20:44  Irif=s=
staging 2017-06-03 20:43 374k
s T Nbrary indexjson 20T 0000 200 JSON I 203 b
LS Q{ package_ArduCAM _indexjson 2017-06-03 20:58 JSON 32§ 14 KB
¢ || package ArduCAM indexjson.sigitmp  2017-06-03 20:43  TMP {4 0 KB
[&f package_indexjson 2017-06-03 20:58 JSON 37 181 KB
[ ] package_indexjson.sig 2017-06-03 20:58  SIG {4 1 KB
E] preferences.txt 2017-06-03 20:48 3 KB

5.2 Using Arduino IDE

After installation of ArduCAM ESP8266 UNO board add-on package, you can select this board
from the Tool->Board menu.

And there several ready to use examples from the File->Examples->ArduCAM. You can use these
examples directly or as a starting point to develop your own code.
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Select ArduCAM_ESP8266_UNO board from Tools->Board menu.

€9 ArduCAM ESP8266 Capture | Arduino 1.8.1 - m] X
File Edit Sketch Tools Help
Auto Format Cirl+T
Archive Sketch
ArduCAM_ESPg Fix Encoding & Reload

// ArduCAM Mini Serial Monitor Ctrl+Shift+M ol
// Web: http://w Serial Plotter Ctrl+Shift+L
// This program
// of the librar] WiFi101 Firmware Updater
// This demo was lk
{ Board: "ArduCAM ESP8266 UNO" >
// It can take pl
/1 Tt cen take p] CPU Frequency: "80 MHz" >
// The demo sket Flash Size: "4M (3M SPIFFS)" >
// 1. Set the ca Upload Speed: "921600" >
/] 2. if server Bot “CONE" | -

3.1f server.o |conti
i (o '=r er. o Get Board Info lcontiz
//stresming and

Programmer: "USBasp" >
// This program { Burn Bootloader CAM ES
// and use &rduinvror oo cumprrer ur wuUve
v

< >

ArduCAM ESP8266 UNO, 80 MHz, 921600, 4M (3M SPIFFS) on COME

Select the example from
File->Examples->ArduCAM->ESP8266->ArduCAM_ESP8266_Nano_V2_Capture

&8 ArduCAM_ESP8266_Nano_V2_Capture | Arduino 1.8.2 - O X
File Edit Sketch Tools Help
New Ctrl+N
Open... Ctrl+0
Open Recent » |pture
Sketchbook » &
Examples | '
Close Ctrl+W 06.5ensors ?
Save Ctrl+5 07.Display ?
Save As... Ctrl+Shift+5 08.Strings #
09.use L Teb
Page Setup  Curl+Shift+P 10.Starterkit BasicKit N
Print GukD 11.ArduinolSP >
Preferences Ctrl+Comma Bz oy ke photo al.u
pto comtiz
Quit Ctrl+Q Adafruit Circuit Playground >
Bridge i’ ArduCAM_ESP8266 N V1_Capt
rdu ano apture
// This program requires the &xd Ethernet > b duCAM S = - _Vi_-ap
- ArduCAM _ESP8266_Nano V1_Capture2SD
/f and use Arduine IIE 1.6.8 conl  Firmata , :
o ArduCAM ESP8266_Nano V1 _Video2SD
LiquidCrystal > v
3 ArduCAM_ESP8266_Nano V2 _Capture
sD »

ArduCAM ESP8266_Mano V2 _Capture2SD
ArduCAM ESP8266 Mano V2 DeepSleep

SerialCommand

Stepper ArduCAM ESP8266 Nano V2 Video2SD
Temboo - - -
ArduCAM_ESP8266_UNO_Capture

TF‘F‘ ’ ArduCAM_ESP8266_UNO V1_Capture2SD

Wi > ArduCAM ESP8266_UNO V1 _Video25D
ArduCAN Examples for ArduCAM ESP82 ArduCAM _ESP8266_UNO_V2_Capture2SD

ArduCAM | ESPB266 ArduCAM_ESP8266_UNO V2 _Video2SD

ArduCAM _Touch 3 Shield v2 >

ArduinoOTA ¥

DNSServer £

¥ i
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Configure the camera setting. You need to modify the memorysaver.h file in order to
enable OV2640_MINI_2MP or 0V5642_MINI_5MP_PLUS or OV5640_MINI_5MP_PLUS camera
modules.

Only one camera can be enabled at a time. The memorysaver.h file is located at C:\Users\Your
computer name\AppData\Local\Arduino15\packages\ ArduCAM_ESP8266_UNO\hardware\

ArduCAM_ESP8266_UNO\2.2.3\libraries\ArduCAM.

B memoryeaver, 13 |
BE#ifndef |
2 #defin

//There are two steps you need to modify in this file before normal comr
e

//Only ArduCAM Shield series platform need to select camera module, Ard ni series platform doesn't

ware platform, nly one at a time

ra module, only one at a
defined (ARDUCAM SHI

NN NN NN N

5.3 There are 12 examples for both ArduCAM Mini 2MP and ArduCAM Mini 5MP camera
modules. (ArduCAM ESP8266 UNO V1 and ArduCAM_ESP8266_Nano_V1 have been discontinued).

ArduCAM_ESP8266_Nano_V2_Capture: this example uses HTTP protocol to capture still or
video over home wifi network from ArduCAM Mini 2MP/SMP and display on the web browser. You
can change the value of wifiType to select Station or AP mode. If you use Station mode the ssid and
password should be modified before uploading.

€9 ArduCAM ESPB266 Nano V2 Capture | Arduino 182 — ] X
File Edit Sketch Tools Help

ArduCAM_ESPB2E6_Mano_\V2_Captu
ffvou can change the value of wifiType to select Station or AP mode. ~
mﬂr iz AP mode.

E—

int wifiType = 1; // O:Statien 1:AP

/AP mode configuration

/Iefault iz arducam_esp8266. If wou want, you can change the AP _aaid to yvfur
const char #AP_ssid = "arducem_esp8266°;

/Iefault is no password If wou want to set password put your password hefle
const char #AP_passwerd = 77;

/Station mode wou should put vour ssid and password
const char #ssid = "SSID"; // Put your SSID here
conszt char #password = "PASSWORD”: // Put wour PASSWORD here
static const size_t bufferSize = 4096; v
£ >

ArduCAM E
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AP mode:
After uploading, the board IP address is 192.168.4.1. You can figure out the IP address through
the serial monitor. The default serial monitor baudrate setting is 115200bps.

@ coms - o X

ArduCAM Start!
012640 detected.

Shere AP: srducam_esp8266
The password is:

192.168.4.1 h
Server started

[ tutoseroll Newline v | [115200 baud v

From your PC, go to the WiFi setting page. You should see an Access Point (AP) which the SSID
name “arducam_esp8266” on the AP scan result list. Choose the “arducam_esp8266” AP to connect

an»

to it. This AP’s password is “”.

arducam _esp8266 S
° I

5012

zZe

501

ZF

360WiFi-501 2

Finally, open the index.html or video.html, input the IP address obtained from the serial
monitor then take pictures or videos. The html files are located at C:\Users\Your computer name\
AppData\Local\Arduino15\packages\ArduCAM_ESP8266_UNO\hardware\ArduCAM_ESP8266_UN\
2.2.3\libraries\ArduCAM\examples\ESP8266\ArduCAM_ESP8266_Capture\html_2640

[ Arducam Mini + Esp82t X |+ X

- o
& 0 *| =% a6 -
ArduCAM _ESP8266_0OV2640 Capture Demo

T T T T
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Also you can use ArduCAM_Host_V2.0_Windows Host app. You can download it on:
https://github.com/ArduCAM/Arduino/tree/master/ArduCAM/examples/host app.

1

Network

Port : oo v
Open
Baudrate : 921600 ‘

Pix : (2640 320:240 ¥
Function : |Light v | |Auto &
Mode i [Signle v

CAME!

- u@am

[] SaveInage

Zoom @

FILE

Fils : [ /tenp |

D Server is running!

COMPort Request: plen=undefined&ql=2

ArduCAM_Host V2 View4 - u] 2%

5.4 To reduce power consumption, calling the interface function immediately goes into the
Deep — sleep mode. In this mode, the chip will disconnect all wi-fi connections and data connections
and enter the sleep mode. Only the RTC module will still work and be responsible for the timing of
the chip. This demo is suitable for battery power.

@ ArduCAM ESPB266 Nano V2 DeepSleep | Arduino 1. — O X

File Edit Sketch Tools Help

New ctrlsN
Open... crl+o
Open Recent

Sketchbook

Examples

Close crl+w
Save crrlts

Save As. Ctrl+Shife+S

Page Setup  Ctrl+Shift+P
Print Crl+P

Cirl+Comma

Ctrl+Q

4 repSizep -]

=
&

05.Control >
06.Sensors >
07.Display >
08.Strings >
09.USB >
10.5tarterKit_BasicKit >
11.ArduinolSP >

Examples for any board

Adafruit Circuit Playground >
. ArduCAM _ESPB266 Nano V1 Capture
B 5
neoe ArduCAM ESP8266 Nano V1_Capture2SD
Ethernet > i
) ArduCAM _ESP8266_Nano_V1_Video2SD
Firmata >
ArduCAM ESP8266 Nano V2 Capture
LiquidCrystal >
ArduCAM_ESPB266_Nane_V2_Capture2SD
sD >
ArduCAM ESPB266 Nano V2 DeepSleep
SerialCommand 5 = T
ArduCAM_ESPB266_Nano_V2_Video2SD
Stepper >
ArduCAM _ESP8266_UNO_Capture
Temboo >
ArduCAM ESP8266 UNO_V1_Capture2SD
TET >
i ArduCAM _ESP8266_UNO_V1_Video25D
>
" ArduCAM ESPB266 UNO V2 Capture2SD
Examples for ArduCAM ESPB266 UNO ESPB266 :  ArduCAM_ESP8266_UNO_V2_Video2SD
ArduCAM 5 Shield vz >
ArduCAM Tauch ¥

After uploading ArduCAM_ESP8266_Nano_V2_DeepSleep.Please note that the jumper marked
in red box should be closed. (The jumper should be open when you upload sketches.)

T R S 5 -

SCL SDAVCCGNDSCKMISO MOSICS


https://github.com/ArduCAM/Arduino/tree/master/ArduCAM/examples/host_app
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ArduCAM_ESP8266_Nano_V1_ Capture2SD (or ArduCAM_ESP8266_Nano V2_Capture2SD):
this example takes time elapse still photos using ArduCAM Mini 2MP/5MP and then stored on the
TF/SD card. The LED indicates when the TF/SD card is writing.

ArduCAM_ESP8266_Nano_V1 Video2SD (or ArduCAM_ESP8266_Nano_V2_Video2SD): this
example takes motion JPEG video clips using ArduCAM Mini 2MP/5MP and then stored on the TF/SD
card as AVI format, about 4 minutes to complete.

If any problems or suggestions for the tutorial or the camera kit, please feel free to contact us
by following ways:

Website: www.arducam.com
Email: support@uctronics.com
Tel: +86 025 84271192

Skype: fpgadu

10


http://www.arducam.com/
mailto:support@uctronics.com

